Course Project on Exploratory Data Analysis - Discuss and Share Your Work

Have you defined raw_df_copy before running this cell?

yes I did. I really can’t figure out why am getting the error

I think you missed the (comma) ,
When defining selected_columns.
For eg. it should be like:

selected_columns =[
                  'Age',    # You probably missed this comma
                  'Sex']

Similarly other places as well,
That is why len(selected_columns) returns 4, when the data items in selected_columns is 9.

hmmm, ok. Let me try that. Thank you for your help.

Hey guys when I run import opendatasets as od od.download(dataset_url) the output asks for my Kaggle username and Kaggle key, what does the Kaggle key mean? Where can I find it?

In your Kaggle profile, click on your profile picture then go to

Your Profile > Account > Api Section > Create New Token

This will generate your Kaggle Username and Kaggle Key.

Refer to this post for more clarification.

Hey guys! I am using a students performance CSV !
When I tried to read that csv file I encountered this parser error! Can anyone plz help me clear this issue? Thanks in Advance!

Hello, Can i know how did u cleared that issue?

The error might be because there might be more columns than intended for certain rows(like row no. 7).

You can try:

import pandas as pd
perfomance_df = pd.read_csv('StudentPerfomance.csv'), error_bad_lines=False)
perfomance_df

Or you can you manually look for the rows that have this additional column and remove those.

1 Like

Thank you so much for sorting my query.

Here is a link to my project. Please, feel free to comment or give a suggestion for update.

I am unable to download data from kaggle:

!pip install jovian opendatasets --upgrade --quiet
dataset_url = ‘Daily Power Generation in India (2017-2020) | Kaggle
import opendatasets as od
od.download(dataset_url)

Do I have to create an account on kaggle for dataset to be downloaded?

Can someone please explain the meaning of these two lines:

!pip install jovian opendatasets --upgrade --quiet

!pip install jovian --upgrade -q

Yes, you would need to create an account on Kaggle.
This will give you a Username and a key that is required to download the dataset.

When I enter my username, following is shown:
The dataset has been downloaded and extracted.

But there is no file on the File-Open.
Also, I did not got an option to enter the key.

After it is downloaded and extracted,
Run the next cell with:

# Change this
data_dir = './us-elections-dataset'

Change the 'us-elections-dataset' to where your dataset is extracted to.

Then run the next cell.

import os
os.listdir(data_dir)

This should list the files in the dataset.

opendatasets is a library that helps in downloading datasets from online sources like
Kaggle.

jovian library would be required to use Jovian notebook specific commands like commit and submit.

--upgrade gives the latest version of that library.

q and quiet hides the output of this command.

My first EDA

Thank you very much.

My data set is not extracted anywhere, how to see where it is extracted? When I click on File, open, I do not see any dataset. I only see the jupyter notebook on which I am working for this project.