Error in jovian.commit()

hello,
I am getting error while commiting to jovian. I have tried everything like
jovian.commit(project=project_name,filename=‘covid-19-india-data-analysis’),
jovian.commit(project=project_name)
jovian.commit(project=covid-19-india-data-analysis)
and also simple jovian.commit()
nothing worked . for everything it is showing error like
[jovian] Error: Failed to read the Jupyter notebook. Please re-run this cell to try again. If the issue persists, provide the “filename” argument to “jovian.commit” e.g. “jovian.commit(filename=‘my-notebook.ipynb’)”

please anyone help me out.!

Are you sure you provide the correct filename? (not the project name).

sry @Sebgolos i didn’t get you. filename is the name of jupyter notebook ,isn’t it?? please explain.
According to the example filename given in error filename should be with extension of .ipynb.So according to url of jupyter notebook my filename should be zerotopandas-course-project.ipynb. and I tried this also.
jovian.commit(filename=‘zerotopandas-course-project.ipynb’)
I am still getting same error.
please help me out.

Filename is the name of the notebook file - this is something probably different from the project name.

Try listing the directory with os.listdir(). The file ending with .ipynb is the name of your notebook file.

1 Like

yeah i got my mistake .I am working on different directory. Now my issue solved. Thank you very much @Sebgolos :innocent: :innocent: :innocent:.