Folium install error

Towards the beginning of the workbook for Assignment 2 we have the line

!pip install opendatasets scikit-learn plotly folium --upgrade --quiet

which when ran in google colab gives me the error: “ERROR: datascience 0.10.6 has requirement folium==0.2.1, but you’ll have folium 0.12.1 which is incompatible.”

The rest of the code works fine but I fear that if I submit the code as is for marking it will not meet the “pass” criteria as the code will not run error free. Can we delete folium from the above line? Please advise on how to proceed with the assignment submission (without failing).

Thanks in advance,


I don’t think we need folium anywhere in the assignment, so probably we can remove folium from the above line.

Ah, thank you for clarifying.

1 Like