I can't save my work from colab to jovian

when I try to commit any project to jovian, it shows the following error :

[jovian] Detected Colab notebook...

[jovian] Please enter your API key ( from https://jovian.ai/ ):
API KEY: ··········
[jovian] Uploading colab notebook to Jovian…

ApiError Traceback (most recent call last)
in ()
----> 1 jovian.commit(project=‘01-tensor-operations’)

1 frames
/usr/local/lib/python3.6/dist-packages/jovian/utils/colab.py in perform_colab_commit(project, privacy)
45 if res.status_code == 200:
46 return res.json()[‘data’]
—> 47 raise ApiError('Colab commit failed: ’ + pretty(res))

ApiError: Colab commit failed: (HTTP 400) Unauthorized access to sadiqbasit782/01-tensor-operations

1 Like

This is what I experience too, I wish we could have timely solution to that.

Hey @gbadamus @abdulbee sorry for the late reply. Can you guys please verify if the API key and the project is from the same account? This is a possible scenario, let me know about this. I’ll also investigate if there is any possible bug.

Yes, my project is from my account, Though I was able to save my project on jovian with binder. But, colab failed me .

1 Like

Yes, they’re from the same account

However, this problem is only with google colab. When I tried running the notebooks from my local computer, the commit worked fine. it worked fine with paperspace too.

So, I’ve been using paperspace, and everything works fine.

I think in the mean time, you should run the notebooks on your local computer, or get a free notebook on paperspace.

That way, you’ll be able to meet deadlines for the assignments

Hi everyone, I am still facing this issue. Does anyone know how to resolve this? Thanks in advance.

Hello @des520mond, Welcome to the forum.
Kindly verify the following,

  • Check if you are giving the correct API Key. You will find the API key in your Jovian Profile on the Get Started Tab.
  • Are you executing the first cell in the colab notebook? Make sure to not make any changes in the first cell, just execute the first cell as it is.

If you are still facing issues after verifying the above steps, Kindly reply back to the forum.

Hi @birajde , the first cell is working fine. The error appears when I use jovian.commit(project=‘01-pytorch-basics’) command. The error message is exactly the same with Sadiq. I have also reset the integrations setting with Google Drive but it still shows me the error. Do you know how to resolve this please? Thank you.

Hi @des520mond, do you see an exception or error when you run jovian.commit? Can you share a screenshot?

Hi @sidujjain , it shows ApiError as shown in the screenshot below.

Thank you.

It seems that you’re trying to upload the notebook as a different user (desmond97teo).

Do you have 2 accounts?

Hi @Sebgolos , I only have one account (des520mond). The account desmond97teo is my Gmail. Thank you.

It seems like the code used to send the notebook has an old/different name. Did you change your name here or was it like that since beginning?

If you did change the name, I would suggest restarting the notebook and running all cells again.

Hi @Sebgolos , I have used this username (des520mond) since the beginning. I have also tried to restart the notebook and rerun all cells but it is still not working. If it is really the username issue, is there anyway to check/modify the username used to connect Colab? Thank you.

Put this into some cell:

from jovian.utils.api import get_current_user

You will be asked for API key. In return you should get your user ID along with username used to publish the project.

1 Like

@des520mond try this:

  • logout and login once from jovian.ai
  • restart kernel on Colab
  • run jovian.commit as usual

I understand why it’s happening, will fix. But for now logout/login should work for you.


Hi @Sebgolos and @sidujjain, thank you so much for your help. It’s working now and I have submitted my first assignment. Thanks again.

I’m getting the same problem. plz help

I tried this but it didn’t ask to upload api