Kaggle Dataset API Error

I’m not able to do the course project due an api error. I tried everything to fix this issue but
still it gives the error.
Can somwone please help me with this?

Are you sure you’ve provided valid credentials?

  • Kaggle user name
  • API key (NOT your user password)

Yep, I copied the right the key and also the saved the .json file in the .kaggle directory as it says.

Are you using local setup or do you use online service?

I tried both ways, and still it won’t work.
I also tried it on a different PC.

When using online services, you have to consider that they can’t access your local PC. You can fix that by uploading the credentials file or using environment variables.

When working locally, you need to make sure that the file is in correct directory (mentioned here). Or use envvars.

Just note that environment vars are a bit insecure, since you have to include your key in the notebook. You could use getpass() though.

What kind of error are you experiencing anyway? All the messages seem to be a bit cryptic.

Does the kaggle command work when using outside the notebook (local setup)?

Sir can I share a screen shot with you as I’m finding it a little difficult to explain the issue

Any sort of details is good :stuck_out_tongue:


Hi, I had the same problem as yours. When I looked at the URL copied from Kaggle.com, it looked something like this:

I went with that, it didn’t work. But, as I removed '/datasets' from the URL, it worked:

1 Like