Kernel crashed during merge

Hello there ,

Every time I am trying to merge data-frames kernel is crashing.
Moreover, despite I run ‘restart & clear output’ , I receive an error message
when I am trying to save my project and I really need to start from the beginning.

This is the error I received every time I am trying to save the second step of assignment.

try adding ‘.ipynb’ extension to your notebook.

Nope dear, that is not the case. I did it but error exist.
Thank you for your time.

Can you share a link to your notebook?

Sure, here it is. Without second part saved since the error occurred.

Hello @xaritos30, you have to provide filename in filename argument and project name in project argument.

Project name is the name that you give to your project it can be anything according to your project and what you are working on.

Filename is the name of your ipynb file. It is the name with which the jupyter notebook is saved in your pc.

It will be like:

jovian.commit(project="project_name", filename="filename")

Here it is, nothing is working!

From the image you have provided, looks like your project name is “zerotopandas-course-vac-charis” and from the notebook link you have provided above, your filename is “zerotopandas-course-project.ipynb” unless you have started working in another notebook.

So try this:
jovian.commit(project="zerotopandas-course-vac-charis", filename="zerotopandas-course-project.ipynb"

And also make sure you don’t make any spelling mistakes.

Are you working on jupyter lab?

Sorry @ayush-mishra-ald, but where did you see this: "and from the notebook link you have provided above, your filename is “zerotopandas-course-project.ipynb” ?
I am asking bcz maybe is something that I can’t understand.
On my 1st screenshot it is stated that:
jovian.commit(project="zerotopandas-course-vac-charis", and
updating notebook "xaritos30/zerotopandas-course-vac-charis" on
So I am assuming that the name of filename should be xaritos30/zerotopandas-course-vac-charis
OR zerotopandas-course-vac-charis.
Am I correct?

Thanks for your help.

Ah ok now I understood, Yeap you are right. This is another issue. I don’t know why is saving with different name.

If you provided the project name correct, then it should update the notebook hosted on Jovian with new version.

Make sure your project name is similar to the previous committed notebooks. A simple spelling mistake can lead to creating a new project rather than updating the old one on Jovian.

I experienced such too.
I think the kernel crashes if your syntax is a bit not correct.
I had to remove that cell and other cells worked perfectly.

Hello guys the issue with saving is still continuing. Is anybody here that can help?

Try without the extension.