Python practice assignment is corrupted

Hey all,

I was very close to to finalise my solution to the last option exercise on the twitter analysis when I got an error that got corrupted.

I have tried to download the file and reupload and remains corrupted. I have attached the screenshots to show you what it looks like.

Hopefully I don’t have to re-do it completely

Please try accessing previous versions of the notebook from the version-selection dropdown on the right.

If you have been committing regularly, you should be able to access previous versions.

1 Like


Thanks so much for the quick response.

I can see the different versions indeed! However I do I go about opening them up via binder?



Once you select a version from the version dropdown, then clicking the “Run” button will run that specific version.

I was unable to achieve what you mentioned. I tried to recreate it and run it from scratch again, was able to upload/hand it, however now after the upload it seems to be corrupted again.

Mine quit processing the code, yesterday all the code I wrote in the jupiter notebook ran and everything was working. Got up today to complete the last assignment problem and reran some code that worked yesterday and it does not return any results in the next block.

I don’t want to rerun anymore cells of code fearing they won’t run and I can’t show that the code worked.

Restarted the kernel, notebook works for a while then quits processing code. Seems like is messing with it when the notebook is committed