Why isn't ImageFolder and DataLoader put into one thing?

Hey guys! If imagefolder and dataloader have very similar roles, why don’t they put them both into one function?

DataLoader is required to load the data into our model in batches.
Whereas, ImageFolder is required to load data from folders containing images.