Zsh: command not found: jovian

When following instructions for Option 2: Running on your computer locally, I get an error when trying to use jovian to clone the assignment notebook. Jovian seem to have been installed but when running:
jovian clone aakashns/first-steps-with-python

I get this error message: " zsh: command not found: jovian".

Where should the Jovian command be located?

Thank you.

Just guessing here…
Are you in a Conda environment?
The command jovian is available in a python virtual environment.
I typically run in a bash environment, not sure about setting up python virtual environments in zsh.
I went ahead and allowed the miniconda installer to add some cruft to my .bashrc
When I’m not doing a course here I can always deactivate back to a plain shell.

@commd it should work in zsh shell too. Just make sure that you have activated correct conda env.

1 Like

Yes, but I’m following the directions. Where should the jovian command be?

I’ve tried the base virtual environment and the newly virtual environment and the command is not found.

I’ve tried both the newly created intro-to-python and the base environments w/o success.

Are you sure you installed the jovian module in the virtual environment?
something along the lines of…
pip install jovian
or pip3 if you don’t have an alias or soft link to the version 3 pip

I’ve recreated my virtual environments a few times and still had that command in my bash history :nerd_face:
That is what brings the jovian command into being present in a virtual environment. Start a python shell and if you can import jovian without throwing an error you have the module. If you throw an error then use the command above to bring jovian into that virtual environment.
If it’s a problem with zsh I can’t help. Me n00b, me stick wif Uboontoo for ease of use and stuff :grinning:

Thank you for your response. I found where the command was located. It was located here:

Once I added it to my path, it ran fine. But I had problems running the ‘python-os-and-filesystem’ notebook when trying to read from urls using urllib.request. I would get a SSLCertVerificationError.

Then I upgraded to Python 3.8.5 and ran the ‘Install Certificates.command’ script that came with it and now all is working well.

Thanks again for your response.

1 Like

That looks like a System directory. Leads me to believe you are still not following Best Practice and running in a Python Virtual Environment. You will make things so much easier on yourself going forward if you put in the extra effort now to learn Virtual Environments that set up most of the environment variables ($PATH being among them) for you so don’t have to go chasing your own tail for solutions to things that aren’t problems inside the virtualenv.

The other point is just as scary. All too often of late, with these tutorials anyway, the first and typically common troubleshoot is to update modules and suddenly everything works again as advertised. The scary part is that this tech is advancing so quickly that when a simple
pip install --update <package-name>
doesn’t solve a problem I might be so far behind the curve I won’t ever catch up.

1 Like